#emc-devel | Logs for 2009-04-08

[01:52:13] <SWPadnos> thanks skunkworks
[02:10:15] <cradek> cradek has changed the topic to: EMC2 development -- http://linuxcnc.org/ | 2.3 schedule: beta2 available for testing, development open on TRUNK | channel logged by logger_dev
[12:14:43] <skunkworks> SWPadnos: thank you! :)
[15:38:43] <CIA-2> EMC: 03eric-johnson 07TRUNK * 10emc2/src/emc/usr_intf/ (emcrsh.cc emcsched.cc schedrmt.cc shcom.cc shcom.hh): Updated help, some cleanup, ready to test
[16:33:59] <fenn_> fenn_ is now known as fenn
[20:40:47] <cradek> can someone test Peter B's stepconf problem in hardy?
[20:42:30] <SWPadnos> I'm betting it's from the long-standing gnome/gtk bug that requires you to move the mouse off then back on a button before you can click it
[20:42:36] <SWPadnos> but I can't test to be sure
[20:42:49] <cradek> yeah, me too, but it doesn't show that behavior in dapper
[20:42:56] <cradek> (I hate that bug and I can't believe it's not fixed)
[20:43:00] <SWPadnos> heh
[20:43:25] <SWPadnos> I can see the argument against changing it, but there must be some middle ground that's actually useful
[20:43:43] <cradek> I don't think there's an argument against fixing it is there?
[20:43:46] <SWPadnos> yes
[20:43:50] <cradek> what is it?
[20:44:06] <SWPadnos> consider a pop-up window that sticks a button under the mouse, just before the user clicks
[20:44:20] <SWPadnos> possibly from a different program or something
[20:44:40] <cradek> hmm
[20:44:45] <SWPadnos> the current behavior doesn't allow the mis-click through, the user has to move away and then exlpicitly move back and click
[20:44:47] <cradek> not sure I believe that's a real problem
[20:44:59] <SWPadnos> I think that was the argument anyway, from when I read that (long) thread
[20:45:06] <jcoby> yeah it was
[20:45:13] <cradek> I don't doubt someone made that argument :-)
[20:45:58] <SWPadnos> middle ground could be that you need that behavior if the program didn't have explicit focus before the click, but do it the way we think is right if it's the same damned program :)
[20:46:27] <jcoby> or just don't worry about it like every other os in the world
[20:46:42] <SWPadnos> that would be non-middle-ground ;)
[20:46:51] <SWPadnos> but yeah, that's a possibility too
[20:47:14] <jcoby> it's better than not responding to the click
[20:47:19] <cradek> popping up your dialogs on top of their parent would be a middle ground with no irritation
[20:47:22] <SWPadnos> hey, that guy with the opto-22 module racks is now selling them for $19.95 instead of $24.95
[20:47:34] <cradek> I dunno
[20:47:45] <jcoby> cradek: that would be the osx way
[20:47:46] <SWPadnos> but still under the focused program?
[20:48:08] <cradek> I don't think it happens often enough to care (I am just about to click something AND a thing pops up AND it has its button under where my mouse happens to be AND I don't notice it in time AND something bad happens?)
[20:48:23] <SWPadnos> you are not an idiot
[20:48:26] <cradek> just sounds like a pretty lame excuse for not fixing it
[20:48:27] <SWPadnos> (if I may say so)
[20:48:33] <SWPadnos> sure
[20:48:36] <jcoby> but it could and it might and that's bad! heh
[20:48:49] <SWPadnos> extreme paranoia about unexpected behavior
[20:49:00] <SWPadnos> for the 0.001% of the time that it could happen
[20:49:03] <cradek> I'll trade that for the next/next/next/next/finish that we all want working
[20:49:28] <SWPadnos> just make the hotkey for all of those be alt-N, and do away with the mouse altogether
[20:49:42] <jcoby> blasphemy! trading user experience over minute security issues?
[20:49:57] <SWPadnos> yep, I'm a heretic
[20:49:59] <cradek> it's truly bizarre that it works for me here - others are saying it's broken for them too.
[20:50:11] <SWPadnos> I just told that to the Mormons who came by today
[20:50:21] <cradek> I don't think I did anything to fix that bug (although I pondered trying some of the patches that are floating around)
[20:50:47] <SWPadnos> are you going all the way through the axes and on to the spindle page?
[20:50:51] <cradek> yes
[20:50:54] <SWPadnos> hmmm
[20:51:21] <SWPadnos> are there emc2.3 beta sim packages?
[20:51:31] <cradek> yes
[20:51:43] <SWPadnos> ok, I'll install that on my laptop and see what happens here
[20:58:41] <SWPadnos> well, works for me here, on RIP 2.3 and TRUNK
[20:58:59] <SWPadnos> though the images (popup and stepconf) do look different between the two
[21:03:04] <cradek> would you post that result so everyone knows I'm not crazy? (I wonder what the pattern is)
[21:03:21] <cradek> ohhh do you use click to focus or focus follows mouse?
[21:03:43] <cradek> I bet almost everyone but me uses CTF
[21:04:17] <SWPadnos> not sure
[21:04:25] <SWPadnos> I think it's CTF
[21:04:37] <SWPadnos> I'm checking 2.2 now
[21:05:59] <SWPadnos> ok, that works too
[21:06:19] <SWPadnos> I even tried positioning the cursor over where I knew the button would pop up, and it worked
[21:06:29] <SWPadnos> I'll email the list in a little bit, gotta run at the moment
[23:36:52] <CIA-2> EMC: 03bigjohnt 07v2_3_branch * 10emc2/docs/src/config/stepconf.lyx: explain a bit more on homing setup
[23:37:51] <CIA-2> EMC: 03bigjohnt 07TRUNK * 10emc2/docs/src/config/stepconf.lyx: explain a bit more on homing setup